多日分析與網友苦戰~部份開機無畫面異常解決方法

Toppc

榮譽會員
已加入
2004/12/19
訊息
11,385
互動分數
207
點數
63
(寫在最前面下一代平台應該會全面邁入純UEFI的世界...這陣痛是必然的.也是必經的)

在AMD平台 X570開始 就有部份網友因為某些板廠預設開機為UEFI MODE


導致 停在02的問題(當然 裡面有部份跟本次案例相同,有部份不是)
經排解(別懷疑呀..不少其它板廠的使用者一樣會問我問題.我一樣會幫忙分析)
發現DP線換成HDMI可以部份解決!

直到Z490 MSI也改成默認UEFI MODE
瞬間換MSI客訴增加.....


經幾位網友幫忙 協助實驗(其實換HDMI就好了 但很感謝他們還配合我用TEST版BIOS實驗問題)
真的很感謝這些熱心網友幫忙

首先 先講答案 目前有兩位更新顯卡VBIOS後解決(DP 1.2線正常 DP 1.4線正常)
顯卡為MSI 2080及2080 TI各一片
(找VGA BIOS可以上這網站 還蠻多的)https://www.techpowerup.com/vgabios/

另一位是索泰1080TI火神EXTREME 正在刷新中(這網友比較不熟 我先請他找好教程確定OK後再刷)

幾個現象 這邊我寫詳細點.方便大家比對 但也不要對號入座就是了(畢竟有些X570卡02的 我還沒發現怎排除)
共通現象 沒畫面時按NUM LOCK是可以切換的

一.用螢幕附贈的DP 1.2線 異常(直接進桌面的 也有除錯燈號卡A1的)
這有兩位 其中一位 換DP1.2或DP1.4線解決(當然DP 1.2是他上網另外買的線)
另一位是換HDMI 解決 後面發現 關閉NV的G-SYNG 也有幫助
這兩位是索泰2060S

二 用螢幕附的DP 1.2線 異常 開機無畫面直接進到桌面才正常顯示(估計也是VGA BIOS不支持 到了桌面驅動起來了才點亮)
換DP 1.4線解決

三 用螢幕DP線 冷開機偶發直接進桌面才有畫面 WINDOWS下選重開機不會
關閉G-SYNG解決(換HDMI也可以解決)

四 用螢幕附贈DP 1.2線 進BIOS黑畫面 (但直接進WINDOWS正常)
換HDMI解決(目前正在請對方找朋友試看看能否更新VGA BIOS試看看)

其中有個實驗 是將BIOS內的開機MODE改成CSM MODE
將開機切回CSM MDOE DP問題就解決了(上面實例3/4都是如此)
但這樣作法不是斧底抽薪 因為清除CMOS後 又會回到UEFI MODE
最終建議還是將VGA BIOS更新到UEFI MODE正常的V-BIOS版本
網上找不到的 請找原VGA廠商索取(但浪費那些時間..真不如隨便買條HDMI)

簡單講 VGA BIOS 在使用DP 1.2線(尤其是螢幕附贈的)上看來之前的卡還存在DP相容性問題
但大多數換成DP 1.4的線或HDMI就解決了..只是沒料到還有個G-SYNG來參一腳

有網友看到文章後給我這LINK說如果是開機導引沒畫面 到桌面有畫面的 可以下載這解決
https://www.nvidia.com/en-us/drivers/nv-uefi-update-x64/

MSI Z490選項在這邊 給大家參考
UEFI-1.png


UEFI-2.png
 
最後編輯:
  • Like
Reactions: w917818 and im_baby

xxxEVA

進階會員
已加入
2006/09/24
訊息
384
互動分數
1
點數
18
A卡(GPUZ看UEFI有勾勾)+free sync也會耶
我是DP HDMI雙螢幕
通常開機進win之前只有HDMI螢幕有畫面
但進BIOS之後幾秒DP螢幕大多數還是會出現畫面
本來以為是新螢幕開機太慢
把sync關掉之後
就有很大機率變成DP螢幕比較早有畫面